欢迎光临
我们一直在努力

WordPress: 可选的模组imagick未被安装或已被禁用

解决 WordPress 5.x 站点健康( Site Health )检查提示

可选的模组imagick未被安装或已被禁用

安装依赖

# yum install ImageMagick-devel

安装imagick

下载 imagick

https://pecl.php.net/package/imagick

# wget https://pecl.php.net/get/imagick-3.4.4.tgz
# tar zxvf imagick-3.4.4.tgz
# cd imagick-3.4.4
# /usr/local/php/bin/phpize
Configuring for:
PHP Api Version:         20180731
Zend Module Api No:      20180731
Zend Extension Api No:   320180731
# ./configure --with-php-config=/usr/local/php/bin/php-config
# make
# make install

我这里php安装在 /usr/local/php/

修改 php.ini 添加扩展, 重启 php-fpm 即可

extension=imagick

 

 

转载本站文章请注明,转载自:IT技术资讯 [https://www.ithothub.com]

本文链接:https://www.ithothub.com/wordpress/202004011554540.html

赞(0) 打赏

评论 抢沙发

评论前必须登录!

 

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏