欢迎光临
我们一直在努力

学会这个,再也不怕Python环境安装 (CentOS 6 Python2.7 & Python3.7)

为什么举例来说这个安装过程呢, 因为现在开发部署的主流linux就是CentOS,而大部分人目前所使用的版本是CentOS Linux release 7.x
该系统已经自带集成了 Python2.7版本及pip,如果没有也可以通过yum方式安装。而CentOS 6则自带Python2.6.6 且没有pip。而现行大多数的Python开源项目都要求Python在2.7及以上,所以如果你要部署项目的机器是CentOS 6, 则需要升级Python版本并安装pip。看起来就这点东西,但是在执行过程中会遇到许多问题,接下来一步一步给你讲解,让你从根上理解Python多环境安装。

没别的需求,只想安装pip

针对pip的安装普遍使用2种方式,一种是yum安装,一种是源码包安装,这个直接在百度搜索也可以搜到一大把有用的内容。这里2种方式都分别介绍一下

centos7

如果你的机器上没有pip,可以执行如下命令

yum -y install python-pip
复制代码

如果安装失败,根据提示解决对应问题,有的人可能需要先安装epel-release

yum -y install epel-release
yum -y install python-pip
复制代码

centos6

cd /opt/
wget https://pypi.python.org/packages/11/b6/abcb525026a4be042b486df43905d6893fb04f05aac21c32c638e939e447/pip-9.0.1.tar.gz#md5=35f01da33009719497f01a4ba69d63c9

tar -xzvf pip-9.0.1.tar.gz
cd pip-9.0.1
python setup.py install
复制代码

最新方法(并不适用所有人)

这也是官方文档中说明的方法, 但是对于某些操作系统及Python版本不会成功
pip官方文档

# 下载安装脚本
cd /opt/
curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py
# 运行安装脚本
python get-pip.py
复制代码

注意:用哪个版本的 Python 运行安装脚本,pip 就被关联到哪个版本

 python3 get-pip.py    # 运行安装脚本。pip关联到了python3
 python2 get-pip.py    # 运行安装脚本。pip关联到了python2
复制代码

多版本Python安装共存

在看下文之前,建议先观看==>只有理解了虚拟环境才算真正掌握 Python 环境

这里选用centos6来做讲解,会更有代表性,会有各种各样的问题发生,当然你也可能不会发生,这和你执行的顺序有关。

前文已经说过,centos6 默认自定了 Python2.6 版本,那么现在直接动手装一个 Python2.7 的版本来做演示。 你问我为什么不直接上Python3.7+,不为什么,就是想搞事情(因为公司项目不支持python3,且必须是python2.7以上,后续升级3.7)话不多说,看下面命令:

# step 1
cd /opt/
wget http://python.org/ftp/python/2.7.3/Python-2.7.3.tar.bz2 #下载python 版本包
tar -jxvf Python-2.7.3.tar.bz2 # 解压文件
# step 2
cd Python-2.7.3  # 进入文件夹
# 检查安装平台属性,系统是否有编译时所需要额库,以及库的版本是否满足编译需要
./configure 
make all &&  make install && make clean && make distclean  # 编译安装及清理
# step 3
mv /usr/bin/python /usr/bin/python2.6.6  # 移动备份原Python 指令
ln -s /usr/local/bin/python2.7 /usr/bin/python #设置Python bin命令的软连接指向 
复制代码

此时输入Python -V,会显示如下结果

[root@alpha-silvergrd-107-13 Python-2.7.3]python -V
Python 2.7.3
复制代码

然而因为我是先实践了之后才来写文章的,所以有些命令我没执行, 为了后面方便演示,我说下我本机的情况, step 3中我执行的是
ln -s /usr/local/bin/python2.7 /usr/bin/python2.7,所有我的效果如图

这个地方需要我解释吗?各位看官问问身边的同事就好或者百度就行,就不赘述了。

注意

如果已经先执行了上一个标题内容 #只想安装pip,那么你就有麻烦了,如果没有,那你就没什么大麻烦!!

先安装了pip

因为你之前已经安装了pip, 而那个时候你系统的Python版本是2.6,所以pip被关联上了Python2.6, 此时如果你使用这个命令python2.7 -m pip install scrapy,会报如下错误,这是因为Python2.7没有与之关联的匹配pip


python -m pip install scrapy则不会

cd /opt/
cd pip-9.0.1
python2.7 setup.py install # pip关联到Python2.7上
复制代码

注意:用哪个版本的 Python 运行安装脚本,pip 就被关联到哪个版本
再次执行就没有此错误了

没有安装pip,现在想安装pip

cd /opt/
wget https://pypi.python.org/packages/11/b6/abcb525026a4be042b486df43905d6893fb04f05aac21c32c638e939e447/pip-9.0.1.tar.gz#md5=35f01da33009719497f01a4ba69d63c9

tar -xzvf pip-9.0.1.tar.gz
cd pip-9.0.1
# 2者选其一,看情况
python2.7 setup.py install(python setup.py install)
复制代码

如何使用

现在多版本Python和pip 都已经安装好了,那么如何使用它来下载一个包呢?
这里以安装一个scrapy为例

python2.7 -m pip install scrapy -i https://pypi.tuna.tsinghua.edu.cn/simple
# or
python -m pip install scrapy -i https://pypi.tuna.tsinghua.edu.cn/simple

# python2.7: 使用的语言版本
# -m: 将模块当作脚本运行
# -i:使用镜像源
复制代码

各种报错如何解决

因为不是边操作边写的文章,其实在执行的过程中遇到了挺多错误的,但是这些错误我也不太记得是在哪些步骤发生的了,所有统一归类在这里,如果正好你遇到了,可以直接照着解决,centos6问题较多,centos7不会有这么多问题。
这里以centos6为例,因为问题多。

No module named setuptools

wget --no-check-certificate https://bootstrap.pypa.io/ez_setup.py
python2.7 ez_setup.py --insecure
复制代码

pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available

在./configure过程中,如果没有加上–with-ssl参数时,默认安装的软件涉及到ssl的功能不可用,刚好pip过程需要ssl模块,而由于没有指定,所以该功能不可用。

解决办法是重新对python2.7.3进行编译安装,用以下过程来实现编译安装:

# 查看openssl安装包,发现缺少openssl-devel包
rpm -aq|grep openssl-devel
# yum安装openssl-devel 
yum install openssl-devel -y 
# 查看安装结果 
rpm -aq|grep openssl 
# 重新对python2.7进行编译安装,用一下过程来实现编译安装
cd /opt/Python2.7.3
./configure --with-ssl #添加ssl选项
make all &&  make install && make clean && make distclean
复制代码

No module named _sqlite3

yum install sqlite-devel
cd /opt/Python2.7.3
./configure
make all &&  make install && make clean && make distclean
复制代码

yum 不可用

vi /usr/bin/yum
复制代码

开头的第一行内容#!/usr/bin/python使用了python,如果你的python版本变了,也就是python -V不是最初的内容了,你需要把这个内容改为原先的python内容,比如

mv /usr/bin/python /usr/bin/python999
复制代码

那么#!/usr/bin/python就要改为#!/usr/bin/python999。 当然你也可以找匹配当前python版本的yum源文件内容进行替换,但不建议(麻烦)

(不建议)yum不可用的情况(/lib64/libc.so.6:version GLIBC_2.14)

参考:Linux/Centos下/lib64/libc.so.6: version `GLIBC_2.14′ not found
但不建议,这里对系统层面的改动比较大,如果是生产服务器,很难预估风险。

(建议)yum不可用的情况(No module named yum)

通常这种情况可以采用如下方式修复,重新下载系统原有的包进行安装修复

# 下载对应操作系统rpm包
wget http://mirrors.ustc.edu.cn/centos/6.10/os/x86_64/Packages/python-2.6.6-66.el6_8.x86_64.rpm
wget http://mirrors.ustc.edu.cn/centos/6.10/os/x86_64/Packages/python-devel-2.6.6-66.el6_8.x86_64.rpm
wget http://mirrors.ustc.edu.cn/centos/6.10/os/x86_64/Packages/python-libs-2.6.6-66.el6_8.x86_64.rpm
wget http://mirrors.ustc.edu.cn/centos/6.10/os/x86_64/Packages/python-pycurl-7.19.0-9.el6.x86_64.rpm
wget http://mirrors.ustc.edu.cn/centos/6.10/os/x86_64/Packages/python-setuptools-0.6.10-4.el6_9.noarch.rpm
wget http://mirrors.ustc.edu.cn/centos/6.10/os/x86_64/Packages/python-urlgrabber-3.9.1-11.el6.noarch.rpm
wget http://mirrors.ustc.edu.cn/centos/6.10/os/x86_64/Packages/python-iniparse-0.3.1-2.1.el6.noarch.rpm
wget http://mirrors.ustc.edu.cn/centos/6.10/os/x86_64/Packages/rpm-python-4.8.0-59.el6.x86_64.rpm
wget http://mirrors.ustc.edu.cn/centos/6.10/os/x86_64/Packages/yum-3.2.29-81.el6.centos.noarch.rpm
wget http://mirrors.ustc.edu.cn/centos/6.10/os/x86_64/Packages/yum-metadata-parser-1.1.2-16.el6.x86_64.rpm
wget http://mirrors.ustc.edu.cn/centos/6.10/os/x86_64/Packages/yum-utils-1.1.30-41.el6.noarch.rpm
wget http://mirrors.ustc.edu.cn/centos/6.10/os/x86_64/Packages/yum-plugin-fastestmirror-1.1.30-41.el6.noarch.rpm
wget http://mirrors.ustc.edu.cn/centos/6.10/os/x86_64/Packages/yum-plugin-protectbase-1.1.30-41.el6.noarch.rpm
wget http://mirrors.ustc.edu.cn/centos/6.10/os/x86_64/Packages/yum-plugin-aliases-1.1.30-41.el6.noarch.rpm
wget http://mirrors.ustc.edu.cn/centos/6.10/os/x86_64/Packages/yum-utils-1.1.30-41.el6.noarch.rpm
wget http://mirrors.ustc.edu.cn/centos/6.10/os/x86_64/Packages/yum-utils-1.1.30-41.el6.noarch.rpm
wget http://mirrors.ustc.edu.cn/centos/6.10/os/x86_64/Packages/yum-utils-1.1.30-41.el6.noarch.rpm
wget http://mirrors.ustc.edu.cn/centos/6.10/os/x86_64/Packages/yum-utils-1.1.30-41.el6.noarch.rpm
wget http://mirrors.ustc.edu.cn/centos/6.10/os/x86_64/Packages/yum-3.2.29-81.el6.centos.noarch.rpm
wget http://mirrors.ustc.edu.cn/centos/6.10/os/x86_64/Packages/yum-utils-1.1.30-41.el6.noarch.rpm

# 安装(依赖报错的话缺什么下什么)
rpm -Uvh --replacepkgs rpm-python*.rpm
rpm -Uvh --replacepkgs yum*.rpm
# or
rpm -Uvh --replacepkgs yum*.rpm –force --nodeps
复制代码

No module named zlib

yum install zlib
# 重新编译Python
./configure --with-zlib
make all &&  make install && make clean && make distclean
复制代码

pip is a package and cannot be directly executed

pip install -U pip
pip install -U setuptools
pip install wheel
复制代码

总结

有些内容没有细讲也有部分忘记了,可能每个人遇到的问题也不同,我挑了个遇到问题最多的来说,上文中已经共存了Python2.6和Python2.7两个版本,那在这基础上再添加其他的Python版本也是同样的操作再来一遍,依次重复操作。唯一有变化的就是包下载的不同。

那么如果你有疑问可以在底部留言评论,我会一一解答,顺便也回忆一下我在这个过程中忘记了的事。

其实还可以使用venv、conda来解决这类问题,但是不想依赖第三方工具,所以没研究,后续会补充这方面文章。

转载本站文章请注明,转载自:IT技术资讯 [https://www.ithothub.com]

本文链接:https://www.ithothub.com/python/2020052511583210.html

赞(0) 打赏

评论 抢沙发

评论前必须登录!

 

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏